Pump looses prime

Pool pumps, filters and the plumbing of swimming pools. Problems relating to the piping and pumping of the swimming pool water.

Pump looses prime

Postby Dave » Tue 21 Mar, 2006 08:20

Pump picks up ok. when it turns off for a period, sometimes looses prime. I also hear water gurgling through the sand filter valve. Should the cell hold its water when the pump stops?
Dave
 

Pool pump prime problem

Postby Pool Helper » Tue 21 Mar, 2006 17:14

If the pump and filter are above the water level, you probably have a leaky o-ring or gasket somewhere. It would most likely be the filter lid or the pump basket cover.

If you turn the multiport valve to closed after turning off the pump, do you still lose prime? If not, the problem is most likely at or after the filter. It could also be the multiport valve or any of the threaded connections before or after the filter.

If the filter is above pool level, the water above the central pipe may flow back to the skimmer if there is no check valve on the suction line. This would cause the "gurgling sound".
Pool Helper
 

Re: Pool pump prime problem

Postby dave » Tue 11 Apr, 2006 05:20

The filer and equipment are above pool level. I find the spa (above pool level) drains back into the pool.
I tried pressurising the system with compressed air and using soapy water; did not find anything.
I am at my witts end about this.
Other info:
I had a problem with a broken pipe at skimmer basket. Fixed.
The waste outlet at filter valve was taking in air. Lubed valve - fixed.

The problem is that when I turn the pump off it takes a while to pull the air into the pump basket.
Of a moning I see the chlorinator cell still full of water and the basket with no prime.
My best guess at the moment is that the water through gravity is being pulled back down to the pool and air is sucked in pre pump from somewhere.
Might try isolating by closing multi valve pre pump and seeing if basket holds its prime.
dave
 

Pool pump priming

Postby Pool Helper » Tue 11 Apr, 2006 14:42

You should consider a check valve on the suction line (preferably) or on the return line. This would prevent the spa and filter emptying back to the pool and would probably solve the priming problem.

One of the biggest concerns I have in situations such as yours is that the water flowing from the spa to the skimmer is flowing backwards - it is backwashing the filter and pushing the dirt into the pool via the skimmer.
Pool Helper
 

DE coming into pool and spa drains into pool after pump off

Postby Susan » Sun 16 Apr, 2006 13:53

Our problem sounds similar. Just before having our pool resurfaced (fiberglas), the spa began draining into the pool after the pump turned off for the night. After the resurfacing and the pump is turned off, we have DE coming into the pool via the main drain. When we cut off the main drain valve, the DE instead comes through the skimmer.

Are these symptoms related or do I possibly have a clog in one of the lines? My theory was that there was a partial vacuum in the lines when the pump was turned off, and DE got sucked back in at that point.
Susan
 

Pump Looses Prime

Postby dschwab » Mon 11 Sep, 2006 22:34

I have solved the problem.

The mechanical Seal.

A guy in a pool shop set me straight. He said that 90% percent of the pumps they get in will have their mech seals replaced as a routine maintenance thing.
It was a little difficult to replace as I have not pulled down a pump before. However I got there in the end.

Pump basket now holds water.
dschwab
 

Pump Looses Prime

Postby Dave P » Tue 14 Jun, 2011 11:38

My pump is losing prime after shutdown and I noticed a possible leak between the motor and pump. Is there a seal between the parts that would fix both problems?
Dave P
 

[Show] Post a reply


Return to Pool Pumps, Filters, Plumbing & Piping


Pool Maintenance   •   Pool Wizard   •   Pool Help   •   Havuz Bakımı
cron